spree_volume_pricing_multi_currency

Spree extension to make volume pricing gem work with spree_multi_currency gem.

Last updated on: May 23 at 11:13 PM

source code bug tracker request upgrade
Opensource
0 0 0
0 / 0
owner:  nwb

SpreeVolumePricingMultiCurrency

volume pricing would be one issue when we use multi currency, as this is not supported in volume pricing gem. this Gem is to make up that gap.

Installation

  1. Add this extension to your Gemfile with this line: ruby gem 'spree_volume_pricing_multi_currency', github: 'nwb/spree_volume_pricing_multi_currency'

  2. Install the gem using Bundler: ruby bundle install

  3. Copy & run migrations ruby bundle exec rails g spree_volume_pricing_multi_currency:install

  4. Restart your server

If your server was running, restart it so that it can find the assets properly.

Testing

First bundle your dependencies, then run rake. rake will default to building the dummy app if it does not exist, then it will run specs. The dummy app can be regenerated by using rake test_app.

bundle
bundle exec rake

When testing your applications integration with this extension you may use it's factories. Simply add this require statement to your spec_helper:

require 'spree_volume_pricing_multi_currency/factories'

Contributing

If you'd like to contribute, please take a look at the instructions for installing dependencies and crafting a good pull request.

Copyright (c) 2018 natural wellbeing inc., released under the New BSD License

comments

No comments yet

Add article
compatible spree versions
tags spree versions
master >= 3.1.0, < 4.0
authors
You